C2503#wr t ###### Current configuration: ! version 10.2 ! hostname C2503 ! enable password test ! username C4000 password cisco (See username explanation in the following section.) ipx routing 0000.0c09.509f ipx gns-response-delay 1000 isdn switch-type basic-dms100 ! interface Ethernet0 ipx network 8022A ipx encapsulation SAP ! interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 encapsulation ppp bandwidth 56 ipx network 8022B no ipx route-cache ipx watchdog-spoof dialer idle-timeout 300 dialer map ipx 8022B.0000.0c02.e649 name C4000 speed 56 broadcast 14155551234 dialer map ipx 8022B.0000.0c02.e649 name C4000 speed 56 broadcast 14155556789 dialer hold-queue 5 dialer load-threshold 100 dialer-group 1 isdn spid1 408555432101 5554321 isdn spid2 408555987601 5559876 ppp authentication chap ! access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 452 access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 453 access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 457 access-list 900 permit -1 ipx route 8022C 8022B.0000.0c02.e649 ipx route 301586E0 8022B.0000.0c02.e649 ! ipx sap 4 NW410 301586E0.0000.0000.0001 451 2 ! ! dialer-list 1 list 900 ! line con 0 line aux 0 line vty 0 4 password test login ! end
C2503#wr t ###### Current configuration: ! version 10.2 ! hostname C2503 ! enable password test ! username C4000 password ciscoThe username "C4000" is the hostname of the remote router and is used by the dialer map command below. The username is case sensitive and must match the remote router's hostname exactly.
The password, which is used by the CHAP authentication process, is case sensitive and must match the remote router's password exactly.
Note: To avoid confusion, the unencrypted form of the password cisco is shown in this sample configuration. In the actual configuration, the password would appear in its encrypted form: 7 13061E010803, where 7 denotes the encryption type and 13061E010803 is the encrypted form of the password cisco. When entering or making changes to the username command, always type the password in its unencrypted form and do not enter the encryption type (7). It is set automatically.
ipx routing 0000.0c09.509f
ipx gns-response-delay 1000
isdn switch-type basic-dms100
interface Ethernet0
ipx network 8022A
ipx encapsulation SAP
Cisco supports the following frame types:
Novell Frame Type Cisco EncapsulationIf you're running a 3.11 (or earlier) file server your frame type may be Ethernet 802.3. The router defaults to 802.3. To verify what frame type you have, check the file server's autoexc.ncf file.Novell Ethernet_II arpa Novell Ethernet_802.3 novell-ether IEEE 802.2 sap IEEE 802.2 SNAP snap
interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 encapsulation ppp
bandwidth 56
Note: This command does not control the speed of your ISDN line. It sets the correct reference point for the BRI port's show interface statistics, for the dialer load-threshold command, and for IGRP/EIGRP routing metrics.
ipx network 8022B
no ipx route-cache
ipx watchdog-spoof
dialer idle-timeout 300
dialer map ipx 8022B.0000.0c02.e649 name C4000 speed 56 broadcast 14155551234
dialer map ipx 8022B.0000.0c02.e649 name C4000 speed 56 broadcast 14155556789
Note: The command parameters for this example are:
8022B.0000.0c02.e649 = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
name C4000 = the hostname of the remote router. The name is case sensitive and should match the name configured for the username command above.
speed 56 = sets the dialer speed to 56k for ISDN circuits that are not 64k end-to-end, and should be included in both routers' dialer map statements. Most installations in North America must be configured for 56K.
broadcast = allows the forwarding of broadcast packets. Unless broadcast packets are specified as interesting packets by the dialer-list command, they will only be forwarded when the ISDN link is active.
14155551234
14155556789 = the remote router's ISDN telephone numbers.
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 452
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 453
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 457
access-list 900 permit -1
Note: The command parameters for this example are:
access-list 900 deny -1 -1 0 -1 452 defines all SAP packets as uninteresting. access-list 900 deny -1 -1 0 -1 453 defines all RIP packets as uninteresting. access-list 900 deny -1 -1 0 -1 457 defines all security packets as uninteresting. access-list 900 permit -1 defines all other packets as interesting.
Note: The command parameters for this example are:
8022C = the external IPX network number of the remote network. To determine this number, type config at the remote server's console prompt and use the LAN protocol statement.
8022B.0000.0c02.e649 = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
ipx route 301586E0 8022B.0000.0c02.e649
Note: The command parameters for this example are:
301586E0 = the network portion of the remote server's internal IPX address. To determine this address, type show ipx servers at the remote router's console prompt.
8022B.0000.0c02.e649 = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
ipx sap 4 NW410 301586E0.0000.0000.0001 451 2
Note: The command parameters for this example are:
4 = SAP type (server)
NW410 = name of SAP service
301586E0.0000.0000.0001 = internal IPX network and host address of remote server. To determine this address, type show ipx servers at the remote router's console prompt.
451 = socket (port) number of remote server, which is determined by the command show ipx servers on the remote router.
2 = RIP hop count to the remote server.
dialer-list 1 list 900
line con 0 line aux 0 line vty 0 4 password test login ! end
C4000#wr t ###### Current configuration: ! version 10.2 ! hostname C4000 ! enable password test ! username C2503 password cisco (See username explanation in the following section) ipx routing 0000.0c02.e649 ipx gns-response-delay 1000 isdn switch-type basic-dms100 ! interface Ethernet0 ipx network 8022C ipx encapsulation SAP ! interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 encapsulation ppp bandwidth 56 ipx network 8022B no ipx route-cache ipx watchdog-spoof dialer idle-timeout 300 dialer map ipx 8022B.0000.0c09.509f name C2503 speed 56 broadcast 14085554321 dialer map ipx 8022B.0000.0c09.509f name C2503 speed 56 broadcast 14085559876 dialer hold-queue 5 dialer load-threshold 100 dialer-group 1 isdn spid1 415555123401 5551234 isdn spid2 415555678901 5556789 ppp authentication chap ! access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 452 access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 453 access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 457 access-list 900 permit -1 ipx route 8022A 8022B.0000.0c09.509f ipx route 2EE67FE3 8022B.0000.0c09.509f ! ipx sap 4 NW312 2EE67FE3.0000.0000.0001 451 2 ! ! dialer-list 1 list 900 ! line con 0 line aux 0 line vty 0 4 password test login ! end
C4000#wr t ###### Current configuration: ! version 10.2 ! hostname C4000 ! enable password test ! username C2503 password ciscoThe username "C4000" is the hostname of the remote router and is used by the dialer map command below. The username is case sensitive and must match the remote router's hostname exactly.
The password, which is used by the CHAP authentication process, is case sensitive and must match the remote router's password exactly.
Note: To avoid confusion, the unencrypted form of the password cisco is shown in this sample configuration. In the actual configuration, the password would appear in its encrypted form: 7 13061E010803, where 7 denotes the encryption type and 13061E010803 is the encrypted form of the password cisco. When entering or making changes to the username command, always type the password in its unencrypted form and do not enter the encryption type (7). It is set automatically.
ipx routing 0000.0c02.e649
ipx gns-response-delay 1000
isdn switch-type basic-dms100
interface Ethernet0
ipx network 8022C
ipx encapsulation SAP
Cisco supports the following frame types:
Novell Frame Type Cisco EncapsulationIf you're running a 3.11 (or earlier) file server your frame type may be Ethernet 802.3. The router defaults to 802.3. To verify what frame type you have, check the file server's autoexc.ncf file.Novell Ethernet_II arpa Novell Ethernet_802.3 novell-ether IEEE 802.2 sap IEEE 802.2 SNAP snap
interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 encapsulation ppp
bandwidth 56
Note: This command does not control the speed of your ISDN line. It sets the correct reference point for the BRI portπs show interface statistics, for the dialer load-threshold command, and for IGRP/EIGRP routing metrics.
dialer map ipx 8022B.0000.0c09.509f name C2503 speed 56 broadcast 14085554321
dialer map ipx 8022B.0000.0c09.509f name C2503 speed 56 broadcast 14085559876
Note: The command parameters for this example are:
8022B.0000.0c09.509f = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
name C2503 = the hostname of the remote router. The name is case sensitive and should match the name configured for the "username" command above.
speed 56 = sets the dialer speed to 56k for ISDN circuits that are not 64k end-to-end, and should be included in both routers' dialer map statements. Most installations in North America must be configured for 56K.
broadcast = allows the forwarding of broadcast packets. Unless broadcast packets are specified as interesting packets by the "dialer-list" command, they will only be forwarded when the ISDN link is active.
14085554321
14085559876 = the remote router's ISDN telephone numbers.
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 452
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 453
access-list 900 deny -1 FFFFFFFF 0 FFFFFFFF 457
access-list 900 permit -1
Note: The command parameters for this example are:
access-list 900 deny -1 -1 0 -1 452 defines all SAP packets as uninteresting. access-list 900 deny -1 -1 0 -1 453 defines all RIP packets to be uninteresting. access-list 900 deny -1 -1 0 -1 457 defines all security packets as uninteresting. access-list 900 permit -1 defines all other packets as interesting.
Note: The command parameters for this example are:
8022A = the external IPX network number of the remote network. To determine this number, type config at the remote server's console prompt and use the LAN protocol statement.
8022B.0000.0c09.509f = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
ipx route 2EE67FE3 8022B.0000.0c09.509f
Note: The command parameters for this example are:
2EE67FE3 = the network portion of the remote server's internal IPX address. To determine this address, type show ipx servers at the remote router's console prompt.
8022B.0000.0c09.509f = the IPX address of the remote router's BRI interface. To determine this address, type show ipx interface B 0 at the remote router's console prompt.
Note: The command parameters for this example are:
4 = SAP type (server)
NW312 = name of SAP service
2EE67FE3.0000.0000.0001 = internal IPX network and host address of remote server. To determine this address, type show ipx servers at the remote router's console prompt.
451 = socket (port) number of remote server, which is determined by the command show ipx servers on the remote router.
2 = RIP hop count to the remote server.
dialer-list 1 list 900
line con 0 line aux 0 line vty 0 4 password test login ! end